summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-06-24 19:39:11 (GMT)
committerBrad King <brad.king@kitware.com>2014-06-25 18:51:19 (GMT)
commit65624c39e3f435a601760bfcb01d9cafbbfb56c1 (patch)
treecb19db486fefa04d01a2bd4a8f68b380ced4100c /Source/CMakeLists.txt
parent8635ac2330641adfbe45b81047288a6074134ee1 (diff)
downloadCMake-65624c39e3f435a601760bfcb01d9cafbbfb56c1.zip
CMake-65624c39e3f435a601760bfcb01d9cafbbfb56c1.tar.gz
CMake-65624c39e3f435a601760bfcb01d9cafbbfb56c1.tar.bz2
VS14: Add Visual Studio 14 generator (#14982)
Call the generator "Visual Studio 14" without any year because this version of VS does not provide a year in the product name. Copy cmGlobalVisualStudio12Generator to cmGlobalVisualStudio14Generator and update version numbers accordingly. Add the VS14 enumeration value. Teach the platform module Windows-MSVC to set MSVC14 and document the variable. Teach module InstallRequiredSystemLibraries to look for the VS 14 runtime libraries. Teach tests CheckCompilerRelatedVariables, VSExternalInclude, and RunCMake.GeneratorToolset to treat VS 14 as they do VS 10, 11, and 12. Co-Author: Pawel Stopinski <diokhan@go2.pl>
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index c3c24fe..3838cb0 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -426,6 +426,8 @@ if (WIN32)
cmGlobalVisualStudio11Generator.cxx
cmGlobalVisualStudio12Generator.h
cmGlobalVisualStudio12Generator.cxx
+ cmGlobalVisualStudio14Generator.h
+ cmGlobalVisualStudio14Generator.cxx
cmGlobalVisualStudioGenerator.cxx
cmGlobalVisualStudioGenerator.h
cmIDEFlagTable.h