summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorDon Olmstead <don.j.olmstead@gmail.com>2016-10-18 00:50:34 (GMT)
committerBrad King <brad.king@kitware.com>2016-10-25 13:46:21 (GMT)
commit69fc7bf87db33d88af02602fba811b5c5e740a70 (patch)
tree9c506a4e79bc0912107d78cb1f05368399f18c53 /Source/CMakeLists.txt
parente2ed9a70929092ab7b32e036886859e53fbff897 (diff)
downloadCMake-69fc7bf87db33d88af02602fba811b5c5e740a70.zip
CMake-69fc7bf87db33d88af02602fba811b5c5e740a70.tar.gz
CMake-69fc7bf87db33d88af02602fba811b5c5e740a70.tar.bz2
VS: Choose flag map based on the toolset name
MSBuild interprets the `.vcxproj` content based on the `PlatformToolset` setting, so our reverse mapping needs to be based on that setting too. For VS 2010 and above, choose the flag map to match the toolset name rather than the generator VS version. Issue: #16153
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 09c0acf..cf9dbb8 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -680,6 +680,8 @@ if (WIN32)
cmVisualStudioGeneratorOptions.cxx
cmVisualStudio10TargetGenerator.h
cmVisualStudio10TargetGenerator.cxx
+ cmVisualStudio10ToolsetOptions.h
+ cmVisualStudio10ToolsetOptions.cxx
cmLocalVisualStudio10Generator.cxx
cmLocalVisualStudio10Generator.h
cmGlobalVisualStudio10Generator.h