summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorNils Gladitz <nilsgladitz@gmail.com>2014-02-24 22:21:12 (GMT)
committerNils Gladitz <nilsgladitz@gmail.com>2014-02-26 13:15:13 (GMT)
commit6fcd835c0786182c4981f9f640849c5c91100845 (patch)
tree175f71ff77a77de6a93b348d145c0ead7df455e1 /Source/CMakeLists.txt
parentc859d176a15326cd1ef7b5c35908f28313d1be19 (diff)
downloadCMake-6fcd835c0786182c4981f9f640849c5c91100845.zip
CMake-6fcd835c0786182c4981f9f640849c5c91100845.tar.gz
CMake-6fcd835c0786182c4981f9f640849c5c91100845.tar.bz2
CPackWIX: refactor and cleanup
Extract addtional classes and functions which are getting unsightly large. Use some of the coding conventions more consistently.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 175a034..966e0f6 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -562,7 +562,11 @@ if(WIN32)
set(CPACK_SRCS ${CPACK_SRCS}
CPack/WiX/cmCPackWIXGenerator.cxx
CPack/WiX/cmWIXSourceWriter.cxx
+ CPack/WiX/cmWIXDirectoriesSourceWriter.cxx
+ CPack/WiX/cmWIXFeaturesSourceWriter.cxx
+ CPack/WiX/cmWIXFilesSourceWriter.cxx
CPack/WiX/cmWIXRichTextFormatWriter.cxx
+ CPack/WiX/cmWIXPatch.cxx
CPack/WiX/cmWIXPatchParser.cxx
)
endif()