summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2002-08-27 12:36:03 (GMT)
committerKen Martin <ken.martin@kitware.com>2002-08-27 12:36:03 (GMT)
commit716eb198198f982d3670ce83927e791103d11fc0 (patch)
tree0f2101364cd966f0ae4b73864e6630c136ac6305 /Source/CMakeLists.txt
parentb8be208408323fad5179754a66cd40d76e9654e8 (diff)
downloadCMake-716eb198198f982d3670ce83927e791103d11fc0.zip
CMake-716eb198198f982d3670ce83927e791103d11fc0.tar.gz
CMake-716eb198198f982d3670ce83927e791103d11fc0.tar.bz2
fixed bootstrap build to not use LoadCOmmandCOmmand
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index af31977..5aa921b 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -85,6 +85,10 @@ ADD_EXECUTABLE(cmake cmakemain.cxx)
ADD_EXECUTABLE(DumpDocumentation cmDumpDocumentation)
ADD_EXECUTABLE(ctest ctest.cxx)
+IF (UNIX)
+ TARGET_LINK_LIBRARIES(CMakeLib ${CMAKE_DL_LIBS})
+ENDIF (UNIX)
+
TARGET_LINK_LIBRARIES(cmake CMakeLib)
TARGET_LINK_LIBRARIES(DumpDocumentation CMakeLib)
TARGET_LINK_LIBRARIES(ctest CMakeLib)