summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-18 20:22:45 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-19 11:25:43 (GMT)
commit765d783972dbacc336d11803cccf56cdc9aac6c5 (patch)
tree4bc204bfdf18d96e6cf24e9e9724d4a2c13efcc6 /Source/CMakeLists.txt
parent52b80b2643acdd2f31582fe20773cc4c3740b9ad (diff)
downloadCMake-765d783972dbacc336d11803cccf56cdc9aac6c5.zip
CMake-765d783972dbacc336d11803cccf56cdc9aac6c5.tar.gz
CMake-765d783972dbacc336d11803cccf56cdc9aac6c5.tar.bz2
cmSystemTools: Drop old RunCommand method
All calls to this method have been replaced by newer infrastructure. Remove it and the supporting cmWin32ProcessExecution class.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 71fae58..7efaa50 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -363,8 +363,6 @@ if (WIN32)
cmVisualStudioSlnParser.cxx
cmVisualStudioWCEPlatformParser.h
cmVisualStudioWCEPlatformParser.cxx
- cmWin32ProcessExecution.cxx
- cmWin32ProcessExecution.h
)
endif()
endif ()
@@ -540,16 +538,6 @@ endif()
add_executable(cmake cmakemain.cxx cmcmd.cxx cmcmd.h)
target_link_libraries(cmake CMakeLib)
-# Build special executable for running programs on Windows 98.
-# Included on any Windows (unconditional packaging required!).
-if(WIN32)
- if(NOT UNIX)
- add_executable(cmw9xcom cmw9xcom.cxx)
- target_link_libraries(cmw9xcom CMakeLib)
- install(TARGETS cmw9xcom DESTINATION bin)
- endif()
-endif()
-
# Build CTest executable
add_executable(ctest ctest.cxx)
target_link_libraries(ctest CTestLib)