summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-09 13:09:57 (GMT)
committerNils Gladitz <nilsgladitz@gmail.com>2014-09-11 19:23:24 (GMT)
commit858d5a0b3e52dbae635fac5a6944fba23a362f5b (patch)
tree76f2be038609faeb88abfb1d02826aec6250d659 /Source/CMakeLists.txt
parente177e7affb10fc25b71d4c9d9796c9df7fcdb800 (diff)
downloadCMake-858d5a0b3e52dbae635fac5a6944fba23a362f5b.zip
CMake-858d5a0b3e52dbae635fac5a6944fba23a362f5b.tar.gz
CMake-858d5a0b3e52dbae635fac5a6944fba23a362f5b.tar.bz2
Fix if() checks of CMAKE_SYSTEM_NAME on Cygwin
The CMAKE_SYSTEM_NAME is "CYGWIN", but we also define a variable named "CYGWIN" to "1". Avoid allowing if() to expand the "CYGWIN" string as a variable.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index c3f77f4..f9405b3 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -451,7 +451,7 @@ if (WIN32)
endif ()
# Watcom support
-if(WIN32 OR "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Linux")
set_property(SOURCE cmake.cxx APPEND PROPERTY COMPILE_DEFINITIONS CMAKE_USE_WMAKE)
list(APPEND SRCS
cmGlobalWatcomWMakeGenerator.cxx