summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorClinton Stimpson <clinton@elemtech.com>2014-03-14 14:47:37 (GMT)
committerClinton Stimpson <clinton@elemtech.com>2014-03-14 14:48:18 (GMT)
commit91fd99b86532dbf35d8c7396654b9beac058c8f3 (patch)
tree5a1df0250f91360185f5087386a0906e6aa5debb /Source/CMakeLists.txt
parent82a7d54cfe75c399b66c888acfcb5ddb15af547b (diff)
downloadCMake-91fd99b86532dbf35d8c7396654b9beac058c8f3.zip
CMake-91fd99b86532dbf35d8c7396654b9beac058c8f3.tar.gz
CMake-91fd99b86532dbf35d8c7396654b9beac058c8f3.tar.bz2
Encoding: Provide option to configure CMake to use UTF-8 encoding.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 966e0f6..9fb8d9a 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -24,6 +24,11 @@ endif()
set(EXECUTABLE_OUTPUT_PATH ${CMake_BIN_DIR})
+# ensure Unicode friendly APIs are used on Windows
+if(WIN32)
+ add_definitions(-DUNICODE -D_UNICODE)
+endif()
+
# configure the .h file
configure_file(
"${CMake_SOURCE_DIR}/Source/cmConfigure.cmake.h.in"