summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-03-03 17:58:48 (GMT)
committerBrad King <brad.king@kitware.com>2006-03-03 17:58:48 (GMT)
commit93c95f1cc5207d043b4bfaa617a611d1dffc7016 (patch)
tree2fffa0b6b63b2cdf104d6425e213b076c7a84450 /Source/CMakeLists.txt
parentea8c278cd63010f00d12ded3cdde316c5188cd01 (diff)
downloadCMake-93c95f1cc5207d043b4bfaa617a611d1dffc7016.zip
CMake-93c95f1cc5207d043b4bfaa617a611d1dffc7016.tar.gz
CMake-93c95f1cc5207d043b4bfaa617a611d1dffc7016.tar.bz2
BUG: Fixed installation of MacOSX Bundle executables and the corresponding install_name remapping support. Extended the BundleTest test to check that this all works. Part of these fixes required changing the signature of AppendDirectoryForConfig in all generators. It now accepts prefix and suffix strings to deal with whether leading or trailing slashes should be included with the configuration subdirectory.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index db611d0..3868811 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -939,6 +939,8 @@ IF(BUILD_TESTING)
ENDIF(${CMAKE_TEST_GENERATOR} MATCHES "Visual Studio")
IF (APPLE AND CMAKE_COMPILER_IS_GNUCXX)
+ SET(BundleTestInstallDir
+ "${CMake_BINARY_DIR}/Tests/BundleTest/InstallDirectory")
ADD_TEST(BundleTest ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/BundleTest"
@@ -947,7 +949,10 @@ IF(BUILD_TESTING)
--build-generator ${CMAKE_TEST_GENERATOR}
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-project BundleTest
- --test-command BundleTest.app/Contents/MacOS/BundleTest)
+ --build-target install
+ --build-options "-DCMAKE_INSTALL_PREFIX:PATH=${BundleTestInstallDir}"
+ --test-command
+ ${BundleTestInstallDir}/Application/BundleTestExe.app/Contents/MacOS/BundleTestExe)
ADD_TEST(objc++ ${CMAKE_CTEST_COMMAND}
--build-and-test