summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorPedro Navarro <pnavarro@netflix.com>2013-10-22 22:11:22 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-26 14:24:15 (GMT)
commit970c82348babacb918802dbf615b2224313eef55 (patch)
treeca1f6f1466038ecfcfeb56ce8cca0f3231315e93 /Source/CMakeLists.txt
parentddef8a7cfffbbae12f2d2c556651f06346237569 (diff)
downloadCMake-970c82348babacb918802dbf615b2224313eef55.zip
CMake-970c82348babacb918802dbf615b2224313eef55.tar.gz
CMake-970c82348babacb918802dbf615b2224313eef55.tar.bz2
ctest_update: Add support for Perforce p4 client
Teach the ctest_update implementation to use the p4 command-line client to perform updates and extract the list of changes. Add a CTest.UpdateP4 test like those that exist already for the other version control tools. Make the test available when p4 and the p4d server are found. During the test launch p4d in the background to serve a repository from the test directory. Then direct the client toward this server for the duration of the test.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 01e4f88..fd97a20 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -465,6 +465,8 @@ set(CTEST_SRCS cmCTest.cxx
CTest/cmCTestGIT.h
CTest/cmCTestHG.cxx
CTest/cmCTestHG.h
+ CTest/cmCTestP4.cxx
+ CTest/cmCTestP4.h
)
# Build CTestLib