summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-03-31 18:17:23 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-03-31 18:17:23 (GMT)
commitae10b3578d3234db1e379b663657fbdb9d1ac543 (patch)
tree39fd57f7548112c5bb1d3501c9a80fb686911bbf /Source/CMakeLists.txt
parentbc649db7cc51acbd56c145fd884a49f049c8393f (diff)
downloadCMake-ae10b3578d3234db1e379b663657fbdb9d1ac543.zip
CMake-ae10b3578d3234db1e379b663657fbdb9d1ac543.tar.gz
CMake-ae10b3578d3234db1e379b663657fbdb9d1ac543.tar.bz2
ENH: add a wrapper for xcodebuild to get around bug and verbose output
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 077872b..03f5155 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -282,6 +282,11 @@ SET(CPACK_SRCS
ADD_LIBRARY(CPackLib ${CPACK_SRCS})
TARGET_LINK_LIBRARIES(CPackLib CMakeLib)
+IF(APPLE)
+ ADD_EXECUTABLE(cmakexbuild cmakexbuild.cxx)
+ TARGET_LINK_LIBRARIES(cmakexbuild CMakeLib)
+ENDIF(APPLE)
+
# Build CMake executable
ADD_EXECUTABLE(cmake cmakemain.cxx)
TARGET_LINK_LIBRARIES(cmake CMakeLib)
@@ -1088,4 +1093,8 @@ INCLUDE (${CMAKE_SOURCE_DIR}/Source/LocalUserOptions.cmake OPTIONAL)
INSTALL_TARGETS(/bin cmake)
INSTALL_TARGETS(/bin ctest)
INSTALL_TARGETS(/bin cpack)
+IF(APPLE)
+ INSTALL_TARGETS(/bin cmakexbuild)
+ENDIF(APPLE)
+
INSTALL_FILES(${CMAKE_DATA_DIR}/include cmCPluginAPI.h)