summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorDāvis Mosāns <davispuh@gmail.com>2016-10-05 12:56:52 (GMT)
committerBrad King <brad.king@kitware.com>2016-10-06 14:55:59 (GMT)
commitbb1d3370cedceec48c82a523cf35df2207c7db17 (patch)
treea546594957a9d4dce4f22636cb92da48f74ad2b2 /Source/CMakeLists.txt
parentaa57f35ff539a1d43d93e373048f70ce7fd04852 (diff)
downloadCMake-bb1d3370cedceec48c82a523cf35df2207c7db17.zip
CMake-bb1d3370cedceec48c82a523cf35df2207c7db17.tar.gz
CMake-bb1d3370cedceec48c82a523cf35df2207c7db17.tar.bz2
codecvt: Add class for encoding conversion
Add a `codecvt` class that can be used as facet for locale so that it's possible to convert from internal UTF-8 encoding to other encodings such as Windows ANSI codepage.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index ec49481..e574957 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -384,6 +384,8 @@ set(SRCS
cm_sha2.c
cm_utf8.h
cm_utf8.c
+ cm_codecvt.hxx
+ cm_codecvt.cxx
)
set(COMMAND_INCLUDES "#include \"cmTargetPropCommandBase.cxx\"\n")