summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-03-16 17:54:35 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-03-16 17:54:35 (GMT)
commitd30868d952e13e5814d3ed50d96af3ef33db4177 (patch)
tree8b76f95d07d9364767cdb2d8f022840e00dcfd6b /Source/CMakeLists.txt
parent2073646eb1a86d819c29c8e0774a8e072efb4c83 (diff)
downloadCMake-d30868d952e13e5814d3ed50d96af3ef33db4177.zip
CMake-d30868d952e13e5814d3ed50d96af3ef33db4177.tar.gz
CMake-d30868d952e13e5814d3ed50d96af3ef33db4177.tar.bz2
ENH: Make sure to use internal zlib
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index badbf76..2e20be1 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -10,6 +10,8 @@ CONFIGURE_FILE(
INCLUDE_DIRECTORIES(
"${CMake_BINARY_DIR}/Source"
"${CMake_SOURCE_DIR}/Source"
+ ${CMAKE_ZLIB_INCLUDES}
+ ${CMAKE_EXPAT_INCLUDES}
)
# let cmake know it is supposed to use it
@@ -127,7 +129,7 @@ ENDIF (WIN32)
# create a library used by the command line and the GUI
ADD_LIBRARY(CMakeLib ${SRCS})
-TARGET_LINK_LIBRARIES(CMakeLib cmsys ${CMAKE_EXPAT_LIBRARIES} cmzlib)
+TARGET_LINK_LIBRARIES(CMakeLib cmsys ${CMAKE_EXPAT_LIBRARIES} ${CMAKE_ZLIB_LIBRARIES})
IF (UNIX)
TARGET_LINK_LIBRARIES(CMakeLib ${CMAKE_DL_LIBS})
ENDIF (UNIX)