summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-02-05 21:31:37 (GMT)
committerBrad King <brad.king@kitware.com>2009-02-05 21:31:37 (GMT)
commitdc13914cd698b49cbae491c1e1aebbcd44fbe932 (patch)
tree4eaa716c3e2160a7e81125360d83dc9f87241ede /Source/CMakeLists.txt
parentf16a471576199ec275463e35ff17849350c0da79 (diff)
downloadCMake-dc13914cd698b49cbae491c1e1aebbcd44fbe932.zip
CMake-dc13914cd698b49cbae491c1e1aebbcd44fbe932.tar.gz
CMake-dc13914cd698b49cbae491c1e1aebbcd44fbe932.tar.bz2
ENH: Create cmXMLSafe to help escapes in XML
This class provides easy syntax to efficiently insert blocks of data into XML documents with proper escapes. It replaces the old cmCTest::MakeXMLSafe and cmSystemTools::MakeXMLSafe methods which allocated extra memory instead of directly streaming the data.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 210c733..1103c37 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -213,6 +213,8 @@ SET(SRCS
cmVersion.h
cmXMLParser.cxx
cmXMLParser.h
+ cmXMLSafe.cxx
+ cmXMLSafe.h
cmake.cxx
cmake.h
cmakewizard.cxx