summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-07-18 15:13:46 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-07-18 15:14:02 (GMT)
commitfc4f3525133270ccc33ccda6acff6f85006ab457 (patch)
tree31473b60683d51e6c0b747c502bc6f2098f66c56 /Source/CMakeLists.txt
parent407c7415f41fc27578bb0ab2c831e767de575531 (diff)
parentcf0ae55dcb9224b92a95166f17452c56ba5b6213 (diff)
downloadCMake-fc4f3525133270ccc33ccda6acff6f85006ab457.zip
CMake-fc4f3525133270ccc33ccda6acff6f85006ab457.tar.gz
CMake-fc4f3525133270ccc33ccda6acff6f85006ab457.tar.bz2
Merge topic 'server-refactor'
cf0ae55d server: Add support for connections that aren't event based 5ddfb6a4 server: Add connection as part of a request d4f5d35c server: Refactor to make the event loop owned by server object 5acbf08b Tests: Teach Server test to forward exit code from server process Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !552
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index e556ca6..d35b7fb 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -1012,7 +1012,9 @@ target_link_libraries(cmake CMakeLib)
if(CMake_ENABLE_SERVER_MODE)
add_library(CMakeServerLib
+ cmConnection.h cmConnection.cxx
cmFileMonitor.cxx cmFileMonitor.h
+ cmPipeConnection.cxx cmPipeConnection.h
cmServer.cxx cmServer.h
cmServerConnection.cxx cmServerConnection.h
cmServerProtocol.cxx cmServerProtocol.h