summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-01-13 17:57:38 (GMT)
committerBrad King <brad.king@kitware.com>2010-01-13 17:57:38 (GMT)
commitfdbe16c1f4cc22422ae3d923834d4d956263e580 (patch)
tree565013f296f8f34968ee215737b174629f3d60e0 /Source/CMakeLists.txt
parentda36cde059f0e4786d65974decb84c8380ee1624 (diff)
downloadCMake-fdbe16c1f4cc22422ae3d923834d4d956263e580.zip
CMake-fdbe16c1f4cc22422ae3d923834d4d956263e580.tar.gz
CMake-fdbe16c1f4cc22422ae3d923834d4d956263e580.tar.bz2
Use if(CYGWIN) instead of if(WIN32 AND UNIX)
CMake has defined CYGWIN on Cygwin for years, so we no longer need the legacy form of the test. Change based on patch from issue #10122.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 621ac3e..8e3872b 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -425,12 +425,12 @@ SET(CPACK_SRCS
CPack/cmCPackZIPGenerator.cxx
)
-IF(WIN32 AND UNIX)
+IF(CYGWIN)
SET(CPACK_SRCS ${CPACK_SRCS}
CPack/cmCPackCygwinBinaryGenerator.cxx
CPack/cmCPackCygwinSourceGenerator.cxx
)
-ENDIF(WIN32 AND UNIX)
+ENDIF(CYGWIN)
IF(UNIX)
SET(CPACK_SRCS ${CPACK_SRCS}