summaryrefslogtreecommitdiffstats
path: root/Source/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-04-17 20:34:07 (GMT)
committerBrad King <brad.king@kitware.com>2007-04-17 20:34:07 (GMT)
commitfe5386be81b58755124fe3f173b38d6692da2790 (patch)
treeb764b1e5ba16bd549adda49ad1e40c7932da7973 /Source/CMakeLists.txt
parent60befc2e49c147bb59f6b68a8bbb7d442596cde5 (diff)
downloadCMake-fe5386be81b58755124fe3f173b38d6692da2790.zip
CMake-fe5386be81b58755124fe3f173b38d6692da2790.tar.gz
CMake-fe5386be81b58755124fe3f173b38d6692da2790.tar.bz2
ENH: Re-enabling Plugin test now that it should work on MacOSX. I will let it run one night to see what platforms are still not implemented. Currently it is not run on QNX because it is known to not be implemented there.
Diffstat (limited to 'Source/CMakeLists.txt')
-rw-r--r--Source/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
index 7f16987..6841c21 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
@@ -986,8 +986,8 @@ IF(BUILD_TESTING)
--test-command executable
)
- # Disable this test by default until it works everywhere.
- IF(CMAKE_TEST_ENABLE_Plugin)
+ # Disable this test on QNX until support is implemented.
+ IF(NOT QNXNTO)
ADD_TEST(Plugin ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Plugin"
@@ -997,7 +997,7 @@ IF(BUILD_TESTING)
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-two-config
--test-command bin/example)
- ENDIF(CMAKE_TEST_ENABLE_Plugin)
+ ENDIF(NOT QNXNTO)
IF(NOT CMAKE_TEST_DIFFERENT_GENERATOR)
ADD_TEST(kwsys ${CMAKE_CTEST_COMMAND}