summaryrefslogtreecommitdiffstats
path: root/Source/CTest/Curl/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2003-03-18 18:40:15 (GMT)
committerBrad King <brad.king@kitware.com>2003-03-18 18:40:15 (GMT)
commit60976ebe046013ae6abe55b6f113e1ae0f360c5a (patch)
tree8f8137cf4f10d40d65e8fd036fb7f359ceab2f1f /Source/CTest/Curl/CMakeLists.txt
parent37751b55d1d86007747e1c61f405851ad9f8e4c1 (diff)
downloadCMake-60976ebe046013ae6abe55b6f113e1ae0f360c5a.zip
CMake-60976ebe046013ae6abe55b6f113e1ae0f360c5a.tar.gz
CMake-60976ebe046013ae6abe55b6f113e1ae0f360c5a.tar.bz2
BUG: Fixed test for gethostbyname_r and gethostbyaddr_r for ansi support.
Diffstat (limited to 'Source/CTest/Curl/CMakeLists.txt')
-rw-r--r--Source/CTest/Curl/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/Source/CTest/Curl/CMakeLists.txt b/Source/CTest/Curl/CMakeLists.txt
index 984a509..38d4f0d 100644
--- a/Source/CTest/Curl/CMakeLists.txt
+++ b/Source/CTest/Curl/CMakeLists.txt
@@ -205,11 +205,12 @@ CHECK_FUNCTION_EXISTS(utime HAVE_UTIME)
CHECK_FUNCTION_EXISTS(RAND_status HAVE_RAND_STATUS)
CHECK_FUNCTION_EXISTS(RAND_screen HAVE_RAND_SCREEN)
CHECK_FUNCTION_EXISTS(RAND_egd HAVE_RAND_EGD)
-CHECK_FUNCTION_EXISTS(gethostbyname_r HAVE_GETHOSTBYNAME_R)
-CHECK_FUNCTION_EXISTS(gethostbyaddr_r HAVE_GETHOSTBYADDR_R)
CHECK_FUNCTION_EXISTS(gmtime HAVE_GMTIME_R)
CHECK_FUNCTION_EXISTS(localtime HAVE_LOCALTIME_R)
+CHECK_SYMBOL_EXISTS(gethostbyname_r "${CURL_INCLUDES};netdb.h" HAVE_GETHOSTBYNAME_R)
+CHECK_SYMBOL_EXISTS(gethostbyaddr_r "${CURL_INCLUDES};netdb.h" HAVE_GETHOSTBYADDR_R)
+
# sigaction and sigsetjmp are special. Use special mechanism for
# detecting those, but only if previous attempt failed.