summaryrefslogtreecommitdiffstats
path: root/Source/CursesDialog/form/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-08-23 17:46:32 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-08-23 17:46:32 (GMT)
commit3f36d234213fd9e23a9402eabb2198e79c6ebe61 (patch)
tree59a7ab0bfb1f057894061347ae3891d03bdcc0c7 /Source/CursesDialog/form/CMakeLists.txt
parent40cf734152304bd00a1c0895f4e37f0ff87ca43d (diff)
downloadCMake-3f36d234213fd9e23a9402eabb2198e79c6ebe61.zip
CMake-3f36d234213fd9e23a9402eabb2198e79c6ebe61.tar.gz
CMake-3f36d234213fd9e23a9402eabb2198e79c6ebe61.tar.bz2
BUG: add explicit clean up of the cachemanager at exit of programs, so dll destruction is not a problem.
Diffstat (limited to 'Source/CursesDialog/form/CMakeLists.txt')
-rw-r--r--Source/CursesDialog/form/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Source/CursesDialog/form/CMakeLists.txt b/Source/CursesDialog/form/CMakeLists.txt
index b197eb6..618aef2 100644
--- a/Source/CursesDialog/form/CMakeLists.txt
+++ b/Source/CursesDialog/form/CMakeLists.txt
@@ -45,4 +45,8 @@ SET( FORM_SRCS
)
INCLUDE_DIRECTORIES(${CMAKE_FORM_SOURCE_DIR})
-ADD_LIBRARY(cmForm ${FORM_SRCS} ) \ No newline at end of file
+ADD_LIBRARY(cmForm ${FORM_SRCS} )
+TARGET_LINK_LIBRARIES(cmForm ${CURSES_LIBRARY})
+IF(CURSES_EXTRA_LIBRARY)
+ TARGET_LINK_LIBRARIES(cmForm ${CURSES_EXTRA_LIBRARY})
+ENDIF(CURSES_EXTRA_LIBRARY)