summaryrefslogtreecommitdiffstats
path: root/Source/CursesDialog/form/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-08-27 13:01:14 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-08-27 13:01:14 (GMT)
commitc41f7983838a654c830edc94470be4defd0f1686 (patch)
tree648a0b4cf71d39365430d5667db3964f404ef461 /Source/CursesDialog/form/CMakeLists.txt
parenta764593f1d4f67d9b89d0a128c6cd69114097865 (diff)
downloadCMake-c41f7983838a654c830edc94470be4defd0f1686.zip
CMake-c41f7983838a654c830edc94470be4defd0f1686.tar.gz
CMake-c41f7983838a654c830edc94470be4defd0f1686.tar.bz2
COMP: make it build on NetBSD, which has separate curses and ncurses, so
it has to be detected that curses isn't good enough, but ncurses is, and that ncurses.h instead of curses.h is included Alex
Diffstat (limited to 'Source/CursesDialog/form/CMakeLists.txt')
-rw-r--r--Source/CursesDialog/form/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Source/CursesDialog/form/CMakeLists.txt b/Source/CursesDialog/form/CMakeLists.txt
index e5c8ca2..a3d9977 100644
--- a/Source/CursesDialog/form/CMakeLists.txt
+++ b/Source/CursesDialog/form/CMakeLists.txt
@@ -1,7 +1,9 @@
PROJECT(CMAKE_FORM)
INCLUDE_REGULAR_EXPRESSION("^.*$")
-INCLUDE_DIRECTORIES(${CURSES_INCLUDE_PATH})
+INCLUDE_DIRECTORIES(${CURSES_INCLUDE_PATH} "${CMAKE_CURRENT_BINARY_DIR}")
+
+CONFIGURE_FILE(cmFormConfigure.h.in "${CMAKE_CURRENT_BINARY_DIR}/cmFormConfigure.h")
SET( FORM_SRCS
fld_arg.c