summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-09-23 18:13:06 (GMT)
committerStephen Kelly <steveire@gmail.com>2012-09-23 18:13:06 (GMT)
commit92b6d85519a148aa73a4a92468a13bc58f669b3c (patch)
treeeb0849b93380c08ddb890b18de82038e537e7675 /Source/QtDialog/CMakeLists.txt
parent865feff4c114a3fbeeb18c56fd8bb977f3f935f5 (diff)
downloadCMake-92b6d85519a148aa73a4a92468a13bc58f669b3c.zip
CMake-92b6d85519a148aa73a4a92468a13bc58f669b3c.tar.gz
CMake-92b6d85519a148aa73a4a92468a13bc58f669b3c.tar.bz2
Enable deprecated API when using Qt 5.
The QAbstractItemModel::reset() method is deprecated in Qt 5, and therefore not part of the API by default (on non-Windows). The replacement for it is beginResetModel/endResetModel which are available from Qt 4.6 onwards. The minimum version of Qt required is currently 4.4, so enable the deprecated API instead of changing that.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index a1ffa20..29daffd 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -25,6 +25,8 @@ if (Qt5Widgets_FOUND)
qt5_add_resources(${ARGN})
endmacro()
set(QT_LIBRARIES ${Qt5Widgets_LIBRARIES})
+ # Remove this when the minimum version of Qt is 4.6.
+ add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0)
else()
set(QT_MIN_VERSION "4.4.0")
find_package(Qt4 REQUIRED)