summaryrefslogtreecommitdiffstats
path: root/Source/QtDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-08 16:32:28 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-08 16:32:28 (GMT)
commitdcf1b645691a1d31cbbad78a9c6c9dca8d472346 (patch)
tree466101c118ee1038f5a2b7b1bc4be60ca4d7dd34 /Source/QtDialog/CMakeLists.txt
parentd4134352abf69374fdad24d53d67734a135daaa5 (diff)
downloadCMake-dcf1b645691a1d31cbbad78a9c6c9dca8d472346.zip
CMake-dcf1b645691a1d31cbbad78a9c6c9dca8d472346.tar.gz
CMake-dcf1b645691a1d31cbbad78a9c6c9dca8d472346.tar.bz2
OS X: Set CMake.app bundle Info.plist fields (#11694)
Use the Apple Info.plist reference documentation: Core Foundation Keys https://developer.apple.com/library/mac/documentation/General/Reference/InfoPlistKeyReference/Articles/CoreFoundationKeys.html Launch Services Keys https://developer.apple.com/library/mac/documentation/general/Reference/InfoPlistKeyReference/Articles/LaunchServicesKeys.html Cocoa Keys https://developer.apple.com/library/mac/documentation/general/Reference/InfoPlistKeyReference/Articles/CocoaKeys.html modify the Info.plist we create for cmake-gui to add/set fields CFBundleShortVersionString = The release-version-number string LSApplicationCategoryType = UTI that categorizes the app for the App Store NSHumanReadableCopyright = Specifies the copyright notice and drop fields CFBundleGetInfoString CFBundleLongVersionString LSRequiresCarbon Also prepare to set CFBundleVersion = The build-version-number string but leave it commented out as TBD (To Be Determined) for now. The version fields must have form <major>.<minor>.<patch> with integer components. While at it, rename the bundle to end in ".<patch>" instead of "-<patch>" so that it is consistent with the version number and does not look like a packaging increment suffix.
Diffstat (limited to 'Source/QtDialog/CMakeLists.txt')
-rw-r--r--Source/QtDialog/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Source/QtDialog/CMakeLists.txt b/Source/QtDialog/CMakeLists.txt
index ef25294..15f9ef1 100644
--- a/Source/QtDialog/CMakeLists.txt
+++ b/Source/QtDialog/CMakeLists.txt
@@ -112,7 +112,12 @@ endif()
if(APPLE)
set_target_properties(cmake-gui PROPERTIES
- OUTPUT_NAME ${CMAKE_BUNDLE_NAME})
+ OUTPUT_NAME ${CMAKE_BUNDLE_NAME}
+ MACOSX_BUNDLE_INFO_PLIST "${CMAKE_CURRENT_SOURCE_DIR}/Info.plist.in"
+ MACOSX_BUNDLE_SHORT_VERSION_STRING "${CMAKE_BUNDLE_VERSION}"
+ # TBD: MACOSX_BUNDLE_BUNDLE_VERSION "${CMAKE_BUNDLE_VERSION}"
+ MACOSX_BUNDLE_COPYRIGHT "Copyright 2000-2013 Kitware, Inc."
+ )
endif()
set(CMAKE_INSTALL_DESTINATION_ARGS
BUNDLE DESTINATION "${CMAKE_BUNDLE_LOCATION}")