summaryrefslogtreecommitdiffstats
path: root/Source/WXDialog/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2002-09-19 21:35:59 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2002-09-19 21:35:59 (GMT)
commit0415b0db75643e3d0532a2d539b07c4d864b9097 (patch)
tree106233045de77fc9dfba3316defac302d067d758 /Source/WXDialog/CMakeLists.txt
parent3001a9ae80ed22874d235c223f514b8960659842 (diff)
downloadCMake-0415b0db75643e3d0532a2d539b07c4d864b9097.zip
CMake-0415b0db75643e3d0532a2d539b07c4d864b9097.tar.gz
CMake-0415b0db75643e3d0532a2d539b07c4d864b9097.tar.bz2
Add test for gui
Diffstat (limited to 'Source/WXDialog/CMakeLists.txt')
-rw-r--r--Source/WXDialog/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Source/WXDialog/CMakeLists.txt b/Source/WXDialog/CMakeLists.txt
index 962e274..12bdefa 100644
--- a/Source/WXDialog/CMakeLists.txt
+++ b/Source/WXDialog/CMakeLists.txt
@@ -29,6 +29,12 @@ IF ( CMAKE_WX_CAN_COMPILE )
INSTALL_TARGETS(/bin wxCMakeSetup)
+ IF(BUILD_TESTING)
+ ADD_TEST(wxCMakeSetupRunTest
+ ${CMake_BINARY_DIR}/Source/wxCMakeSetup
+ -Q -A:ON -B:${CMake_BINARY_DIR}/Tests/Simple
+ -H:${CMake_SOURCE_DIR}/Tests/Simple)
+ ENDIF(BUILD_TESTING)
ELSE ( CMAKE_WX_CAN_COMPILE )
MESSAGE("Cannot find wxWindows libraries and/or header files")