summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeCommands/target_link_libraries/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-11-25 00:15:44 (GMT)
committerBrad King <brad.king@kitware.com>2013-01-08 19:14:27 (GMT)
commit9ce1b9ef2946ead0605e766c7dcf1302fe122f3a (patch)
treedc757e71d66b28948a587c16e2a8b965ccffde01 /Tests/CMakeCommands/target_link_libraries/CMakeLists.txt
parentc2cde7f1047b2f11e7d4a466000a20d8c42394be (diff)
downloadCMake-9ce1b9ef2946ead0605e766c7dcf1302fe122f3a.zip
CMake-9ce1b9ef2946ead0605e766c7dcf1302fe122f3a.tar.gz
CMake-9ce1b9ef2946ead0605e766c7dcf1302fe122f3a.tar.bz2
Add CMAKE_BUILD_INTERFACE_INCLUDES build-variable.
This makes set(CMAKE_BUILD_INTERFACE_INCLUDES ON) add the equivalent of set_property(TARGET tgt APPEND PROPERTY INTERFACE_INCLUDE_DIRECTORIES $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR};${CMAKE_CURRENT_BINARY_DIR}> ) to every target. If the headers are in CMAKE_CURRENT_SOURCE_DIR, and the generated headers are in CMAKE_CURRENT_BINARY_DIR, this is a convenient way to build a target bar, which depends on foo, just by using target_link_libraries() and adding the INTERFACE_INCLUDE_DIRECTORIES to the INCLUDE_DIRECTORIES of the target being linked. There will be more-convenient porcelain API to consume the property in the future.
Diffstat (limited to 'Tests/CMakeCommands/target_link_libraries/CMakeLists.txt')
-rw-r--r--Tests/CMakeCommands/target_link_libraries/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/CMakeCommands/target_link_libraries/CMakeLists.txt b/Tests/CMakeCommands/target_link_libraries/CMakeLists.txt
index 60b36fc..29b69d9 100644
--- a/Tests/CMakeCommands/target_link_libraries/CMakeLists.txt
+++ b/Tests/CMakeCommands/target_link_libraries/CMakeLists.txt
@@ -53,6 +53,13 @@ set_target_properties(targetA PROPERTIES LINK_INTERFACE_LIBRARIES "")
assert_property(targetA LINK_INTERFACE_LIBRARIES "")
+add_subdirectory(subdir)
+target_link_libraries(targetA subdirlib)
+set_property(TARGET targetA APPEND PROPERTY
+ INCLUDE_DIRECTORIES
+ $<TARGET_PROPERTY:subdirlib,INTERFACE_INCLUDE_DIRECTORIES>
+)
+
target_link_libraries(targetA depB depC)
assert_property(targetA LINK_INTERFACE_LIBRARIES "")