summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLib/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-04-21 16:57:11 (GMT)
committerBrad King <brad.king@kitware.com>2017-04-22 19:19:11 (GMT)
commit7373b389ebf482fd16c70ff0e8b5abf403b4be07 (patch)
tree4dfa2b0d86969bf27ad9e0964d5df8b2a95eeb04 /Tests/CMakeLib/CMakeLists.txt
parenteaf53849ec760ecc1000ab6f56519f203c9b4ff5 (diff)
downloadCMake-7373b389ebf482fd16c70ff0e8b5abf403b4be07.zip
CMake-7373b389ebf482fd16c70ff0e8b5abf403b4be07.tar.gz
CMake-7373b389ebf482fd16c70ff0e8b5abf403b4be07.tar.bz2
Xcode: Drop support for Xcode versions below 3
Diffstat (limited to 'Tests/CMakeLib/CMakeLists.txt')
-rw-r--r--Tests/CMakeLib/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/Tests/CMakeLib/CMakeLists.txt b/Tests/CMakeLib/CMakeLists.txt
index d680205..d1a1df5 100644
--- a/Tests/CMakeLib/CMakeLists.txt
+++ b/Tests/CMakeLib/CMakeLists.txt
@@ -34,16 +34,6 @@ target_link_libraries(CMakeLibTests CMakeLib)
add_executable(testEncoding testEncoding.cxx)
target_link_libraries(testEncoding cmsys)
-# Xcode 2.x forgets to create the output directory before linking
-# the individual architectures.
-if(CMAKE_OSX_ARCHITECTURES AND XCODE
- AND NOT "${XCODE_VERSION}" MATCHES "^[^12]")
- add_custom_command(
- TARGET CMakeLibTests
- PRE_BUILD COMMAND ${CMAKE_COMMAND} -E make_directory "${CMAKE_CFG_INTDIR}"
- )
-endif()
-
foreach(test ${CMakeLib_TESTS})
add_test(CMakeLib.${test} CMakeLibTests ${test} ${${test}_ARGS})
endforeach()