summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Stürmer <michael.stuermer@schaeffler.com>2017-06-21 08:44:54 (GMT)
committerBrad King <brad.king@kitware.com>2017-06-21 12:49:42 (GMT)
commit0db4c7a021437c1b2e0ec788bdda249417501490 (patch)
tree1b7c6791bacb4dd7932cc9189d2d3445bef4ef1b /Tests/CMakeLists.txt
parent782c1e2f3741977104ef7bd2861162d861bf45d3 (diff)
downloadCMake-0db4c7a021437c1b2e0ec788bdda249417501490.zip
CMake-0db4c7a021437c1b2e0ec788bdda249417501490.tar.gz
CMake-0db4c7a021437c1b2e0ec788bdda249417501490.tar.bz2
Tests: Verify registry value is not "/registry" before using
Fixes: #17002
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index d138f58..4bc7839 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2081,7 +2081,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
set(reg_nasm "[HKEY_CURRENT_USER\\SOFTWARE\\nasm]")
foreach(reg vs10 vs11 vs12 vs14 ws80 ws81 ws10_0 wp80 wp81 wince tegra nasm)
get_filename_component(r "${reg_${reg}}" ABSOLUTE)
- if(IS_DIRECTORY "${r}")
+ if(IS_DIRECTORY "${r}" AND NOT "${r}" STREQUAL "/registry")
set(${reg} 1)
else()
set(${reg} 0)