summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-09-16 18:28:51 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-15 14:47:38 (GMT)
commit277bd1db98194fe7b48627add4442e9b7a8207a7 (patch)
tree3a77d9cf12f239d93c0f0c8ffab82f2e79af1c8c /Tests/CMakeLists.txt
parent678aaad1336b9581889d7d219a2778b0b070a560 (diff)
downloadCMake-277bd1db98194fe7b48627add4442e9b7a8207a7.zip
CMake-277bd1db98194fe7b48627add4442e9b7a8207a7.tar.gz
CMake-277bd1db98194fe7b48627add4442e9b7a8207a7.tar.bz2
Drop CMAKE_STRICT mode
With our modern development workflow it is less likely a property will be added to C++ code without documentation. This mode only existed to support the DocTest which had very limited coverage of the properties anyway.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 0e0455c..2f6a456 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -508,9 +508,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/SubProject")
endif()
- if (CMAKE_STRICT)
- ADD_TEST_MACRO(DocTest DocTest)
- endif ()
# macro to add a test that will build a nightly release
# of CMake for given platform using the release scripts
macro(ADD_NIGHTLY_BUILD_TEST name script)