summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-10-28 17:35:53 (GMT)
committerBrad King <brad.king@kitware.com>2009-10-28 17:35:53 (GMT)
commit28c3d59ed930976fd5ac4b5ea4f595632ef54758 (patch)
treecf3067e1271c86c4470085f3e76ab3767f0c2144 /Tests/CMakeLists.txt
parent74c59a748df858aa474342f3ad53e36cf877f9c1 (diff)
downloadCMake-28c3d59ed930976fd5ac4b5ea4f595632ef54758.zip
CMake-28c3d59ed930976fd5ac4b5ea4f595632ef54758.tar.gz
CMake-28c3d59ed930976fd5ac4b5ea4f595632ef54758.tar.bz2
Test per-config OUTPUT_DIRECTORY properties
We test (ARCHIVE|LIBRARY|RUNTIME)_OUTPUT_DIRECTORY_<CONFIG> properties by building COnly as a subdirectory and setting the properties to put its files in specific locations. We build an executable that verifies the targets actually appear where expected.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index ea63835..c9a6372 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -117,6 +117,7 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(COnly COnly)
ADD_TEST_MACRO(CxxOnly CxxOnly)
ADD_TEST_MACRO(IPO COnly/COnly)
+ ADD_TEST_MACRO(OutDir runtime/OutDir)
ADD_TEST_MACRO(NewlineArgs NewlineArgs)
ADD_TEST_MACRO(SetLang SetLang)
ADD_TEST_MACRO(ExternalOBJ ExternalOBJ)