summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorCameron Cawley <ccawley2011@gmail.com>2021-10-18 22:20:07 (GMT)
committerBrad King <brad.king@kitware.com>2022-05-06 14:40:58 (GMT)
commit33da5824acefcb4106ce89fc2278111dc3846c0a (patch)
treeee90b8f17abb3948ab3f3cc1fe592c4f24bcdbcd /Tests/CMakeLists.txt
parent849ad97d9576697b180547d8d850b59e7100c6c0 (diff)
downloadCMake-33da5824acefcb4106ce89fc2278111dc3846c0a.zip
CMake-33da5824acefcb4106ce89fc2278111dc3846c0a.tar.gz
CMake-33da5824acefcb4106ce89fc2278111dc3846c0a.tar.bz2
OpenWatcom: Allow specifying the runtime library
Add a `CMAKE_WATCOM_RUNTIME_LIBRARY` variable to control the runtime library selection. Add policy CMP0136 to switch to in place of the old hard-coded default flags. Fixes: #23178
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 9a1cf69..9cee144 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2077,6 +2077,10 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(ModuleDefinition example_exe)
endif()
+ if (CMAKE_C_COMPILER_ID MATCHES "Watcom" AND WIN32)
+ ADD_TEST_MACRO(WatcomRuntimeLibrary)
+ endif()
+
ADD_TEST_MACRO(CheckCompilerRelatedVariables CheckCompilerRelatedVariables)
if("${CMAKE_GENERATOR}" MATCHES "Makefile" OR