summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-10-11 13:24:24 (GMT)
committerBrad King <brad.king@kitware.com>2019-10-11 13:24:24 (GMT)
commit3709389520f091de10e2c1b7fb8350bacc3a0fb0 (patch)
tree82f6715424de85c4009d172d7b7cee5523601329 /Tests/CMakeLists.txt
parent3e05637280e77d991f2270d13cead0343b13d029 (diff)
parent806e01d638195905b1973c031ef71a4125f50376 (diff)
downloadCMake-3709389520f091de10e2c1b7fb8350bacc3a0fb0.zip
CMake-3709389520f091de10e2c1b7fb8350bacc3a0fb0.tar.gz
CMake-3709389520f091de10e2c1b7fb8350bacc3a0fb0.tar.bz2
Merge branch 'objc-c++flags' into release-3.16
Merge-request: !3904
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 32b580b..b29638b 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2353,6 +2353,18 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/c-file-extension-test")
+ add_test(Objective-C.cxx-file-extension-test ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/Objective-C/cxx-file-extension-test"
+ "${CMake_BINARY_DIR}/Tests/Objective-C/cxx-file-extension-test"
+ --build-two-config
+ ${build_generator_args}
+ --build-project cxx-file-extension-test
+ --build-options ${build_options}
+ --test-command cxx-file-extension-test
+ )
+ list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/Objective-C/cxx-file-extension-test")
+
add_test(Objective-C.objc-file-extension-test ${CMAKE_CTEST_COMMAND}
--build-and-test
"${CMake_SOURCE_DIR}/Tests/Objective-C/objc-file-extension-test"