summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorVedran Vujinovic <vedran.vujinovic@gmail.com>2019-09-04 09:32:10 (GMT)
committerBrad King <brad.king@kitware.com>2019-09-24 14:12:43 (GMT)
commit481070a78a90a7e6c0bfc433fec842c78d63d9de (patch)
treedf1a93a8916994e09b78696e8c96a83b0a4e86ea /Tests/CMakeLists.txt
parentacdb326610416ea3a559740fa79ad807a44838ee (diff)
downloadCMake-481070a78a90a7e6c0bfc433fec842c78d63d9de.zip
CMake-481070a78a90a7e6c0bfc433fec842c78d63d9de.tar.gz
CMake-481070a78a90a7e6c0bfc433fec842c78d63d9de.tar.bz2
Tests: Teach VSWinStorePhone to verify the content of generated appx/msix
Add a test to verify the content of generated UWP app package - appx/msix. MSIX format was introduced Visual Studio 2017 version 15.9.0 and Windows SDK version 17763.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 78ae7aa..c284603 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2079,6 +2079,9 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
--build-config $<CONFIGURATION>
--build-options -DCMAKE_SYSTEM_NAME=${systemName}
-DCMAKE_SYSTEM_VERSION=${systemVersion}
+ --test-command
+ ${CMAKE_CMAKE_COMMAND} -DAPP_PACKAGE_DIR="${CMake_BINARY_DIR}/Tests/VSWinStorePhone/${name}"
+ -P "${CMake_SOURCE_DIR}/Tests/VSWinStorePhone/VerifyAppPackage.cmake"
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/VSWinStorePhone/${name}")
endmacro()