summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-12-04 14:54:18 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-12-04 14:54:18 (GMT)
commit5875801293ae1ba09b15cdc22902ee7766416de5 (patch)
tree31a6176195fa4ac04e964580df33dde40a84c8f0 /Tests/CMakeLists.txt
parent65dc4170f858d561144a3c79397f4d2822bae4b6 (diff)
parent7a3277276e69c92d0f69674cdc27bae11bcbc14f (diff)
downloadCMake-5875801293ae1ba09b15cdc22902ee7766416de5.zip
CMake-5875801293ae1ba09b15cdc22902ee7766416de5.tar.gz
CMake-5875801293ae1ba09b15cdc22902ee7766416de5.tar.bz2
Merge topic 'improve-embarcadero'
7a327727 Embarcadero: Fix erroneous interpretation of __CODEGEARC_VERSION__. 25211d75 Compiler ID: Compiler versions must be a valid, numeric version string. 060442c2 Embarcadero: Check code using CMAKE_CXX_COMPILER_ID and CMAKE_C_COMPILER_ID. f3b3219c Embarcadero/Watcom: Properly skip VSResource test for other generators. ddbda722 Embarcadero: Fix bug where duplicate Ninja job pools would be created.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 6c4567d..509c7ee 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -269,8 +269,7 @@ if(BUILD_TESTING)
set(TEST_RESOURCES TRUE)
endif()
# for borland and watcom there is no resource support
- if("${CMAKE_GENERATOR}" MATCHES "WMake" OR
- "${CMAKE_GENERATOR}" MATCHES "Borland")
+ if(WATCOM OR BORLAND)
set(TEST_RESOURCES FALSE)
endif()
if(TEST_RESOURCES)