summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-12-18 19:26:20 (GMT)
committerBrad King <brad.king@kitware.com>2008-12-18 19:26:20 (GMT)
commit64f419c0e85f9929687c4c159930c8398a299854 (patch)
tree00a4d8bccfc387969b5efc1ffbf038327be97112 /Tests/CMakeLists.txt
parent0a83aa6f5700b424830136ebd2bf285e8ce6b56d (diff)
downloadCMake-64f419c0e85f9929687c4c159930c8398a299854.zip
CMake-64f419c0e85f9929687c4c159930c8398a299854.tar.gz
CMake-64f419c0e85f9929687c4c159930c8398a299854.tar.bz2
BUG: Fix new 'testing' test for CMake releases
The recent change of the 'testing' test to actually drive the tests within it does not work on Windows with released CMakes 2.6.2 and lower if no configuration is given to ctest with a -C option. This works around the problem by detecting the case and changing the empty configuration to Debug.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8ae3041..689c187 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -13,6 +13,11 @@ MACRO(ADD_TEST_MACRO NAME COMMAND)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/${NAME}")
ENDMACRO(ADD_TEST_MACRO)
+# Make sure the 'testing' test gets a proper configuration.
+SET_DIRECTORY_PROPERTIES(PROPERTIES
+ TEST_INCLUDE_FILE "${CMake_SOURCE_DIR}/Tests/EnforceConfig.cmake"
+ )
+
# Testing
IF(BUILD_TESTING)
# Collect a list of all test build directories.