summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2009-07-12 08:51:51 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2009-07-12 08:51:51 (GMT)
commit7048373296482ee38dc7336b3d96df4dc98bcb1b (patch)
tree843e0b1704e2b1979684c1794fdb316a20dade27 /Tests/CMakeLists.txt
parent2a750cacd62e6c84cb2120a9833e0cafd1b8e338 (diff)
downloadCMake-7048373296482ee38dc7336b3d96df4dc98bcb1b.zip
CMake-7048373296482ee38dc7336b3d96df4dc98bcb1b.tar.gz
CMake-7048373296482ee38dc7336b3d96df4dc98bcb1b.tar.bz2
STYLE: don't load CMakeDetermineSystem and CMakeSystemSpecific directly from
cmCTestScriptHandler, but have it load the new script CTestScriptMode.cmake -> that makes it more flexible, also add a simple test that the system name has been determined correctly Alex
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 83e11e3..8982ac3 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -877,6 +877,13 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=CVS -P ${CMake_SOURCE_DIR}/Utilities/Rel
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/BundleGeneratorTest")
ENDIF(APPLE AND CTEST_TEST_CPACK)
+ # A simple test for ctest in script mode
+ CONFIGURE_FILE("${CMake_SOURCE_DIR}/Tests/CTestScriptMode/CTestTestScriptMode.cmake.in"
+ "${CMake_BINARY_DIR}/Tests/CTestScriptMode/CTestTestScriptMode.cmake" @ONLY)
+ ADD_TEST(CTest.ScriptMode ${CMAKE_CTEST_COMMAND}
+ -S "${CMake_BINARY_DIR}/Tests/CTestScriptMode/CTestTestScriptMode.cmake"
+ )
+
SET(CTEST_TEST_UPDATE 1)
IF(CTEST_TEST_UPDATE)
# Test CTest Update with Subversion