summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-11-14 14:04:54 (GMT)
committerBrad King <brad.king@kitware.com>2013-11-18 13:26:22 (GMT)
commit7fc7624af5403e6bff9dbc99da398be314c0b223 (patch)
treeaceb80d7232bff12b2c579db8d287f55cea4e701 /Tests/CMakeLists.txt
parent0a7f17b870ceb03fd8687d630ed6fb875dcdc66a (diff)
downloadCMake-7fc7624af5403e6bff9dbc99da398be314c0b223.zip
CMake-7fc7624af5403e6bff9dbc99da398be314c0b223.tar.gz
CMake-7fc7624af5403e6bff9dbc99da398be314c0b223.tar.bz2
Tests: Move CMAKE_TEST_MAKEPROGRAM into Tests/CMakeLists.txt
Also drop the temporary MAKEPROGRAM variable and the DART_ROOT special case. We never run dashboard clients with Dart anymore.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index b6e945e..1b8b2ec 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -43,6 +43,10 @@ configure_file(${CMake_SOURCE_DIR}/Tests/EnforceConfig.cmake.in
# Testing
if(BUILD_TESTING)
+ if(NOT CMAKE_TEST_DIFFERENT_GENERATOR)
+ set(CMAKE_TEST_MAKEPROGRAM "${CMAKE_MAKE_PROGRAM}")
+ endif()
+
if("${CMAKE_TEST_GENERATOR}" MATCHES "Unix Makefiles" OR ("${CMAKE_TEST_GENERATOR}" MATCHES Ninja AND NOT WIN32))
set(TEST_CompileCommandOutput 1)
endif()