summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-10-14 16:46:55 (GMT)
committerBrad King <brad.king@kitware.com>2020-10-14 20:41:50 (GMT)
commit9952ee063a1a2b31c784733b0cf676b4a6efc36e (patch)
treef019b22a20973bd61f944c002148b8312f64d0bc /Tests/CMakeLists.txt
parentc5559597177eabd5620766e9dbc6f02a3b827ddb (diff)
downloadCMake-9952ee063a1a2b31c784733b0cf676b4a6efc36e.zip
CMake-9952ee063a1a2b31c784733b0cf676b4a6efc36e.tar.gz
CMake-9952ee063a1a2b31c784733b0cf676b4a6efc36e.tar.bz2
server: remove deprecated 'cmake -E server' mode
The server mode has been deprecated since commit 996e1885c4 (server: deprecate in favor of the file-api, 2019-04-19, v3.15.0-rc1~198^2). Clients should now be using the file-api. Remove the server mode.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index f4be4b6..328ab7f 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -240,8 +240,6 @@ if(BUILD_TESTING)
if(NOT CMake_TEST_EXTERNAL_CMAKE)
add_subdirectory(CMakeLib)
-
- add_subdirectory(CMakeServerLib)
endif()
add_subdirectory(CMakeOnly)
add_subdirectory(RunCMake)
@@ -2911,13 +2909,6 @@ if(BUILD_TESTING)
ADD_TEST_MACRO(CMakeCommands.link_directories)
ADD_TEST_MACRO(CMakeCommands.target_link_directories)
- # The cmake server-mode test requires python for a simple client.
- find_package(PythonInterp QUIET)
- if(PYTHON_EXECUTABLE)
- set(Server_BUILD_OPTIONS -DPYTHON_EXECUTABLE:FILEPATH=${PYTHON_EXECUTABLE})
- ADD_TEST_MACRO(Server Server)
- endif()
-
configure_file(
"${CMake_SOURCE_DIR}/Tests/CTestTestCrash/test.cmake.in"
"${CMake_BINARY_DIR}/Tests/CTestTestCrash/test.cmake"