summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorWilliam R. Dieter <william.r.dieter@intel.com>2021-01-26 08:06:52 (GMT)
committerBrad King <brad.king@kitware.com>2021-01-28 14:07:02 (GMT)
commit9b5fd04905811ef5fcae740c9edbf5dca7db0511 (patch)
treeb7040bf94e555a35a55e84a0b98a65a64c04876a /Tests/CMakeLists.txt
parentccdf7c000529782029a9956021a147e214521864 (diff)
downloadCMake-9b5fd04905811ef5fcae740c9edbf5dca7db0511.zip
CMake-9b5fd04905811ef5fcae740c9edbf5dca7db0511.tar.gz
CMake-9b5fd04905811ef5fcae740c9edbf5dca7db0511.tar.bz2
Tests: Disable MFC test for IntelLLVM due to #18311
clang-cl cannot deal with implicit dependencies in UTF16 files (see #18311). IntelLLVM inherits this behavior from Clang. The MFC test uses `rc` in the way described in #18311 and gets the same error described in #18311. Disable the test until #18311 is fixed. Signed-off-by: William R. Dieter <william.r.dieter@intel.com>
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index a633bd2..4ed902c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2018,12 +2018,19 @@ if(BUILD_TESTING)
endif()
endif()
- # For the Watcom WMake generator, avoid the MFC test by default.
if(CTEST_RUN_MFC)
+ # For the Watcom WMake generator, avoid the MFC test by default.
if("${CMAKE_GENERATOR}" MATCHES "WMake")
message(STATUS
"using the Watcom WMake generator, avoiding MFC test")
set(CTEST_RUN_MFC OFF)
+ elseif("${CMAKE_CXX_COMPILER_ID}" STREQUAL "IntelLLVM")
+ # clang-cl cannot deal with implicit dependencies in UTF16 files
+ # (see #18311). IntelLLVM inherits this behavior from Clang.
+ # TODO: maybe clang should also skip the MFC test
+ message(STATUS
+ "using generator other than Visual Studio with clang-cl, avoiding MFC test")
+ set(CTEST_RUN_MFC OFF)
endif()
endif()