summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-06-10 13:29:30 (GMT)
committerBrad King <brad.king@kitware.com>2011-06-10 13:52:18 (GMT)
commita4ec24269b32a28104e1d5681e718024b28bb4e7 (patch)
treefd4b0c30093063aa38bb65e2921d43aee01353fc /Tests/CMakeLists.txt
parent77ddb6a0cd35996f1329d727a25de3460f6aa899 (diff)
downloadCMake-a4ec24269b32a28104e1d5681e718024b28bb4e7.zip
CMake-a4ec24269b32a28104e1d5681e718024b28bb4e7.tar.gz
CMake-a4ec24269b32a28104e1d5681e718024b28bb4e7.tar.bz2
CTest: Report tests not run due to unknown configuration
When add_test(NAME) is called without the CONFIGURATIONS argument then the test is intended to run in any configuration. In multi-config generators like the VS IDE and Xcode tests created by add_test(NAME) can only be run when testing a known configuration (otherwise there is no way to generate the test command line). If no test command line is known for a particular configuration, or if no configuration is given to ctest, report the test as not run instead of silently skipping it. Also fix CMake's own TestsWorkingDirectory test invocation to correct a previously silent failure exposed by this change.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 1be2a24..2ad9a77 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1310,7 +1310,7 @@ ${CMake_BINARY_DIR}/bin/cmake -DVERSION=master -P ${CMake_SOURCE_DIR}/Utilities/
--build-makeprogram ${CMAKE_TEST_MAKEPROGRAM}
--build-exe-dir "${CMake_BINARY_DIR}/Tests/TestsWorkingDirectory"
--force-new-ctest-process
- --test-command ${CMAKE_CTEST_COMMAND} -V
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C \${CTEST_CONFIGURATION_TYPE}
)
LIST(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/TestsWorkingDirectory")