summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-04-29 13:18:14 (GMT)
committerBrad King <brad.king@kitware.com>2020-04-29 13:19:06 (GMT)
commitab7eda2591c04244e23b57f2101ad4ac16c6b367 (patch)
tree93b5d23fae14497faadd4566d8d477dc6af835ff /Tests/CMakeLists.txt
parentd9eb9e785e9873a7b034aec667bd808d34f1a907 (diff)
downloadCMake-ab7eda2591c04244e23b57f2101ad4ac16c6b367.zip
CMake-ab7eda2591c04244e23b57f2101ad4ac16c6b367.tar.gz
CMake-ab7eda2591c04244e23b57f2101ad4ac16c6b367.tar.bz2
Tests: Remove unnecessary pass regex on CTestCoverageCollectGCOV
The test script uses `message(FATAL_ERROR)` on failure, so we can just let the `ctest` exit code determine the result.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index cf8aa14..03ce31e 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -2691,9 +2691,6 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
-S "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/test.cmake" -VV
--output-log "${CMake_BINARY_DIR}/Tests/CTestCoverageCollectGCOV/testOut.log"
)
- set_tests_properties(CTestCoverageCollectGCOV PROPERTIES
- PASS_REGULAR_EXPRESSION
- "PASSED with correct output.*Testing/CoverageInfo/main.cpp.gcov")
set_property(TEST CTestCoverageCollectGCOV PROPERTY ENVIRONMENT CTEST_PARALLEL_LEVEL=)
configure_file(