summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2011-08-17 00:34:23 (GMT)
committerStephen Kelly <steveire@gmail.com>2011-08-17 00:36:22 (GMT)
commitafae7a95a06bf1cbec47b3b4471e5f11a41065cb (patch)
treea56fb8e385b28445731bd3f09b5c3d22ae191902 /Tests/CMakeLists.txt
parent1ae3365e9f4126688d57137648e190ca5f4ef8dc (diff)
downloadCMake-afae7a95a06bf1cbec47b3b4471e5f11a41065cb.zip
CMake-afae7a95a06bf1cbec47b3b4471e5f11a41065cb.tar.gz
CMake-afae7a95a06bf1cbec47b3b4471e5f11a41065cb.tar.bz2
Start testing expected values for compiler flags.
Should help catch unhandled flag warnings so far not handled by check_cxx_compiler_flag FAIL_REGEXen.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index eececb0..aad908c 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -223,6 +223,8 @@ IF(BUILD_TESTING)
ADD_TEST_MACRO(Module.GenerateExportHeader GenerateExportHeader)
+ ADD_TEST_MACRO(Module.CheckCXXCompilerFlag CheckCXXCompilerFlag)
+
ADD_TEST(LinkFlags-prepare
${CMAKE_CTEST_COMMAND} -C \${CTEST_CONFIGURATION_TYPE}
--build-and-test