summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-03-16 20:42:39 (GMT)
committerBrad King <brad.king@kitware.com>2016-03-17 13:32:16 (GMT)
commite903a9fc55a1a8d1e6cc681f8d2e98bb74566ec8 (patch)
tree8cc61086edf0ae8111638757f78dda82ac851951 /Tests/CMakeLists.txt
parentdd630075448f6aa45c0e51444365feb73701ebbd (diff)
downloadCMake-e903a9fc55a1a8d1e6cc681f8d2e98bb74566ec8.zip
CMake-e903a9fc55a1a8d1e6cc681f8d2e98bb74566ec8.tar.gz
CMake-e903a9fc55a1a8d1e6cc681f8d2e98bb74566ec8.tar.bz2
Utilities/Release: Create a Windows 64-bit binary
Compile with `-D_WIN32_WINNT=0x502` to use a WinXP-compatible API. Compile with `-D_USING_V110_SDK71_` to tell the VS standard library headers that we are building with a WinXP-compatible Windows SDK. Link executables with `-subsystem:console,5.02` to make them runnable on Windows XP 64-bit. Ideally `cmake-gui` should instead be linked with `-subsystem:windows,5.02` but with the Ninja and Makefile generators CMake adds `-subsystem:windows` after our `-subsystem:console,5.02` flag and the linker seems to interpret this combination as we need.
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index c14008f..8a256bf 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -686,12 +686,15 @@ ${CMake_BINARY_DIR}/bin/cmake -DDIR=dev -P ${CMake_SOURCE_DIR}/Utilities/Release
if(CMAKE_BUILD_NIGHTLY_RELEASES)
ADD_NIGHTLY_BUILD_TEST(CMakeNightlyWin32
win32_release.cmake)
+ ADD_NIGHTLY_BUILD_TEST(CMakeNightlyWin64
+ win64_release.cmake)
ADD_NIGHTLY_BUILD_TEST(CMakeNightlyOSX
osx_release.cmake)
ADD_NIGHTLY_BUILD_TEST(CMakeNightlyLinux32
linux32_release.cmake)
ADD_NIGHTLY_BUILD_TEST(CMakeNightlyLinux64
linux64_release.cmake)
+ set_property(TEST CMakeNightlyWin64 PROPERTY DEPENDS CMakeNightlyWin32)
endif()
# add tests with more complex invocations