summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-04-23 15:01:38 (GMT)
committerMarc Chevrier <marc.chevrier@gmail.com>2020-04-23 15:47:22 (GMT)
commitf39da773eee5ae018aa5c02352ec9933b9e64d08 (patch)
tree397ef3246b277773a598a64bf2bb22719c6ba8e6 /Tests/CMakeLists.txt
parent8c00f5ef0a29758c56fa46a11e150b0e0f5c364e (diff)
downloadCMake-f39da773eee5ae018aa5c02352ec9933b9e64d08.zip
CMake-f39da773eee5ae018aa5c02352ec9933b9e64d08.tar.gz
CMake-f39da773eee5ae018aa5c02352ec9933b9e64d08.tar.bz2
FindPython: fix python compiler validation
Ensure also the cache of properties is erased in case of multiple searches. Fixes: #20626, #20627
Diffstat (limited to 'Tests/CMakeLists.txt')
-rw-r--r--Tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 33c7514..aff7383 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1470,7 +1470,8 @@ ${CMake_SOURCE_DIR}/Utilities/Release/push.bash --dir dev -- '${CMake_BUILD_NIGH
add_subdirectory(GoogleTest)
endif()
- if(CMake_TEST_FindPython OR CMake_TEST_FindPython_NumPy OR CMake_TEST_FindPython_Conda)
+ if(CMake_TEST_FindPython OR CMake_TEST_FindPython_NumPy
+ OR CMake_TEST_FindPython_Conda OR CMake_TEST_FindPython_IronPython)
add_subdirectory(FindPython)
endif()