summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-02-06 13:33:52 (GMT)
committerBrad King <brad.king@kitware.com>2009-02-06 13:33:52 (GMT)
commit16fe328dfc65f47e0a4fd1f7f1ac8e2fa3663b51 (patch)
tree71d385a536394b58dc42b7e4162baf3078907097 /Tests/CMakeTests/CMakeLists.txt
parent0499ca66aab617409458cc2add56c10c15904e94 (diff)
downloadCMake-16fe328dfc65f47e0a4fd1f7f1ac8e2fa3663b51.zip
CMake-16fe328dfc65f47e0a4fd1f7f1ac8e2fa3663b51.tar.gz
CMake-16fe328dfc65f47e0a4fd1f7f1ac8e2fa3663b51.tar.bz2
BUG: Alternative fix to bug #8423
The patch used to fix this bug used SystemTools::GetRealPath which works only for existing files. It broke the case of using the command get_filename_component for a non-existing file. Also, it changed long-standing behavior in a possibly incompatible way even for existing files. This reverts the original fix and instead updates the documentation to be consistent with the behavior.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 981653d..9f91abc 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -14,7 +14,6 @@ AddCMakeTest(VariableWatch "")
AddCMakeTest(Include "")
AddCMakeTest(FindBase "")
AddCMakeTest(Toolchain "")
-AddCMakeTest(GetFilenameComponentSymlinks "")
SET(GetPrerequisites_PreArgs
"-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"