summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-02-01 14:03:05 (GMT)
committerBrad King <brad.king@kitware.com>2010-02-01 14:03:05 (GMT)
commit3c2ecbe74eb0d01dc276b98b1307b2580b81adc6 (patch)
treec0d14b0e92bd71a7b54d47bf256f020f09c9ba32 /Tests/CMakeTests/CMakeLists.txt
parent17e5e5fcb0d92a9a2a6e94be57499f92e90dd1ba (diff)
downloadCMake-3c2ecbe74eb0d01dc276b98b1307b2580b81adc6.zip
CMake-3c2ecbe74eb0d01dc276b98b1307b2580b81adc6.tar.gz
CMake-3c2ecbe74eb0d01dc276b98b1307b2580b81adc6.tar.bz2
Add alternate per-vendor compiler id detection
At least one Fortran compiler does not provide a preprocessor symbol to identify itself. Instead we try running unknown compilers with version query flags known for each vendor and look for known output. Future commits will add vendor-specific flags/output table entries.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 161ca44..6df026e 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -26,6 +26,7 @@ AddCMakeTest(If "")
AddCMakeTest(String "")
AddCMakeTest(Math "")
AddCMakeTest(CMakeMinimumRequired "")
+AddCMakeTest(CompilerIdVendor "")
if(HAVE_ELF_H)
AddCMakeTest(ELF "")