summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-23 14:07:39 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-23 14:07:39 (GMT)
commitc98aaceb9287329e71ffa060103265cc8fea8d69 (patch)
tree496a818cc9ca6fd3617e30a4eafcbacb62ddd7ca /Tests/CMakeTests/CMakeLists.txt
parent07ea19ad1f280e7a1cb07ab2b52c0081f72251dd (diff)
downloadCMake-c98aaceb9287329e71ffa060103265cc8fea8d69.zip
CMake-c98aaceb9287329e71ffa060103265cc8fea8d69.tar.gz
CMake-c98aaceb9287329e71ffa060103265cc8fea8d69.tar.bz2
ENH: Create ImplicitLinkInfo test
This tests the internal CMakeParseImplicitLinkInfo.cmake module to ensure that implicit link information is extracted correctly. The test contains many manually verified examples from a variety of systems.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index b83518b..32c5412 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -19,6 +19,7 @@ AddCMakeTest(Version "")
AddCMakeTest(Message "")
AddCMakeTest(File "")
AddCMakeTest(SeparateArguments "")
+AddCMakeTest(ImplicitLinkInfo "")
SET(GetPrerequisites_PreArgs
"-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"