summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-03-06 15:04:06 (GMT)
committerBrad King <brad.king@kitware.com>2009-03-06 15:04:06 (GMT)
commitca3b93d9c6a816afd7a07bf218c8884510219cf4 (patch)
treef88d3af0bdb2bb57b17cb737e762901317593dd4 /Tests/CMakeTests/CMakeLists.txt
parent62702551dbf77632f566c92aa2c2555f23fe1557 (diff)
downloadCMake-ca3b93d9c6a816afd7a07bf218c8884510219cf4.zip
CMake-ca3b93d9c6a816afd7a07bf218c8884510219cf4.tar.gz
CMake-ca3b93d9c6a816afd7a07bf218c8884510219cf4.tar.bz2
ENH: Teach message() how to display warnings
This adds message(WARNING) and message(AUTHOR_WARNING) command modes and fully documents the command behavior in all modes.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index e8ed3a3..e197302 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -16,6 +16,7 @@ AddCMakeTest(FindBase "")
AddCMakeTest(Toolchain "")
AddCMakeTest(GetFilenameComponentRealpath "")
AddCMakeTest(Version "")
+AddCMakeTest(Message "")
SET(GetPrerequisites_PreArgs
"-DCTEST_CONFIGURATION_TYPE:STRING=\\\${CTEST_CONFIGURATION_TYPE}"