summaryrefslogtreecommitdiffstats
path: root/Tests/CMakeTests/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-08 16:44:28 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-08 16:44:28 (GMT)
commitd4ada9d0d540ab2dc2a9747315c5afda5887950f (patch)
tree2070d061a0fa5bef543c1b3c3e120e75413295d6 /Tests/CMakeTests/CMakeLists.txt
parentd4e26b7e881f97f1cef31b789a7252708cf1c06b (diff)
downloadCMake-d4ada9d0d540ab2dc2a9747315c5afda5887950f.zip
CMake-d4ada9d0d540ab2dc2a9747315c5afda5887950f.tar.gz
CMake-d4ada9d0d540ab2dc2a9747315c5afda5887950f.tar.bz2
Clean up CMake build tree 'bin' directory
We re-arrange EXECUTABLE_OUTPUT_PATH settings to avoid putting utility and test executables in the 'bin' directory of the build tree. This makes the directory look like that in the installation tree, except that on multi-configuration generators we still use a per-config subdirectory.
Diffstat (limited to 'Tests/CMakeTests/CMakeLists.txt')
-rw-r--r--Tests/CMakeTests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CMakeTests/CMakeLists.txt b/Tests/CMakeTests/CMakeLists.txt
index 6b44417..161ca44 100644
--- a/Tests/CMakeTests/CMakeLists.txt
+++ b/Tests/CMakeTests/CMakeLists.txt
@@ -1,4 +1,4 @@
-SET(CMAKE_EXECUTABLE "${EXECUTABLE_OUTPUT_PATH}/cmake")
+SET(CMAKE_EXECUTABLE "${CMake_BIN_DIR}/cmake")
MACRO(AddCMakeTest TestName PreArgs)