summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestCostSerial/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2011-01-03 16:25:46 (GMT)
committerZach Mullen <zach.mullen@kitware.com>2011-01-03 16:25:46 (GMT)
commit6b0c7ded5777c5b4c703bbe59be5c6afcebb879d (patch)
tree5927fef4d46f4f9ae9c8709421f60b0ab147afba /Tests/CTestTestCostSerial/CMakeLists.txt
parentedff9207ed82d241077d66b20087657f74e8b5b9 (diff)
downloadCMake-6b0c7ded5777c5b4c703bbe59be5c6afcebb879d.zip
CMake-6b0c7ded5777c5b4c703bbe59be5c6afcebb879d.tar.gz
CMake-6b0c7ded5777c5b4c703bbe59be5c6afcebb879d.tar.bz2
Support explicitly set test costs in non-parallel testing.
Diffstat (limited to 'Tests/CTestTestCostSerial/CMakeLists.txt')
-rw-r--r--Tests/CTestTestCostSerial/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/CTestTestCostSerial/CMakeLists.txt b/Tests/CTestTestCostSerial/CMakeLists.txt
new file mode 100644
index 0000000..a9a5c25
--- /dev/null
+++ b/Tests/CTestTestCostSerial/CMakeLists.txt
@@ -0,0 +1,13 @@
+CMAKE_MINIMUM_REQUIRED (VERSION 2.6)
+PROJECT (CTestTestCostSerial)
+INCLUDE (CTest)
+
+ADD_EXECUTABLE (Sleep sleep.c)
+
+FOREACH (index RANGE 1 3)
+ ADD_TEST (TestSleep${index} Sleep)
+ENDFOREACH (index RANGE 1 3)
+
+SET_TESTS_PROPERTIES(TestSleep1 PROPERTIES COST -500)
+SET_TESTS_PROPERTIES(TestSleep2 PROPERTIES COST 12)
+SET_TESTS_PROPERTIES(TestSleep3 PROPERTIES COST 0)