summaryrefslogtreecommitdiffstats
path: root/Tests/CTestTestVerboseOutput/CMakeLists.txt
diff options
context:
space:
mode:
authorZach Mullen <zach.mullen@kitware.com>2015-03-15 17:00:31 (GMT)
committerBrad King <brad.king@kitware.com>2015-03-17 14:11:33 (GMT)
commit874fdd914a646d25096c34b97caafe43e2a77748 (patch)
tree977f364db95e1200a4607777282a9d04511579a6 /Tests/CTestTestVerboseOutput/CMakeLists.txt
parent607131bf8c806b6227e56089eab9252537bd31d8 (diff)
downloadCMake-874fdd914a646d25096c34b97caafe43e2a77748.zip
CMake-874fdd914a646d25096c34b97caafe43e2a77748.tar.gz
CMake-874fdd914a646d25096c34b97caafe43e2a77748.tar.bz2
CTest: Output test-specific env vars in verbose mode (#15446)
Any environment vars that were configured for a test via the ENVIRONMENT property will now be output when the test is run with verbose logging enabled.
Diffstat (limited to 'Tests/CTestTestVerboseOutput/CMakeLists.txt')
-rw-r--r--Tests/CTestTestVerboseOutput/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/CTestTestVerboseOutput/CMakeLists.txt b/Tests/CTestTestVerboseOutput/CMakeLists.txt
new file mode 100644
index 0000000..4cdd29c
--- /dev/null
+++ b/Tests/CTestTestVerboseOutput/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required (VERSION 2.6)
+project(CTestTestVerboseOutput)
+include(CTest)
+
+add_executable(nop nop.c)
+
+add_test(NAME TestWithProperties COMMAND nop)
+set_property(TEST TestWithProperties PROPERTY ENVIRONMENT
+ "foo=bar"
+ "this=that"
+)