summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/Library/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Lindauer <touchstone222@runbox.com>2023-06-25 01:23:39 (GMT)
committerBrad King <brad.king@kitware.com>2023-09-25 16:27:29 (GMT)
commit531b4fe64377b2e2ce5918535df389be0a754b04 (patch)
tree67d6dca1cb123bb8473aa9542cc7e647bff5efa3 /Tests/Complex/Library/CMakeLists.txt
parent10f435a58f97a71f6718bfdd0cacb72175a906ef (diff)
downloadCMake-531b4fe64377b2e2ce5918535df389be0a754b04.zip
CMake-531b4fe64377b2e2ce5918535df389be0a754b04.tar.gz
CMake-531b4fe64377b2e2ce5918535df389be0a754b04.tar.bz2
OrangeC: Add support for OrangeC compiler
Add compiler information modules. Update the test suite. Fixes: #25032 Co-authored-by: Brad King <brad.king@kitware.com>
Diffstat (limited to 'Tests/Complex/Library/CMakeLists.txt')
-rw-r--r--Tests/Complex/Library/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/Complex/Library/CMakeLists.txt b/Tests/Complex/Library/CMakeLists.txt
index 9f2d5e1..d216486 100644
--- a/Tests/Complex/Library/CMakeLists.txt
+++ b/Tests/Complex/Library/CMakeLists.txt
@@ -23,7 +23,7 @@ set(LibrarySources ${LibrarySources}
remove(LibrarySources create_file.cxx GENERATED nonexisting_file)
add_library(CMakeTestLibrary ${LibrarySources})
-if(WIN32 AND NOT CYGWIN AND NOT BORLAND AND NOT MINGW)
+if(WIN32 AND NOT CYGWIN AND NOT BORLAND AND NOT MINGW AND NOT CMAKE_C_COMPILER_ID STREQUAL "OrangeC")
target_link_libraries(CMakeTestLibrary debug user32.lib)
target_link_libraries(CMakeTestLibrary optimized kernel32.lib)
endif()