summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2002-07-16 21:42:56 (GMT)
committerBrad King <brad.king@kitware.com>2002-07-16 21:42:56 (GMT)
commit3d3caacf9ec9f99cebcfaeb5ab105daa1046f945 (patch)
tree7ce557ef4bbce9d386c6db2d4065415642f79b7f /Tests/ComplexOneConfig/CMakeLists.txt
parent08f2876bb438d229388984b851e11bfaa86a6e24 (diff)
downloadCMake-3d3caacf9ec9f99cebcfaeb5ab105daa1046f945.zip
CMake-3d3caacf9ec9f99cebcfaeb5ab105daa1046f945.tar.gz
CMake-3d3caacf9ec9f99cebcfaeb5ab105daa1046f945.tar.bz2
ENH: Added test for IF inside a FOREACH.
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index 0549c6f..2d6de20 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -161,6 +161,20 @@ SET(removeVar1 c e)
REMOVE(REMOVE_STRING ${removeVar1} f)
#
+# Test an IF inside a FOREACH.
+#
+FOREACH(x "a")
+ IF(1)
+ # Should always execute.
+ SET(IF_INSIDE_FOREACH_THEN_EXECUTED 1)
+ ELSE(1)
+ # Should never execute.
+ SET(IF_INSIDE_FOREACH_ELSE_EXECUTED 1)
+ ENDIF(1)
+ENDFOREACH(x)
+
+
+#
# Configure file
# (plug vars to #define so that they can be tested)
#